Access to Exchange mailbox

Major incident Email & Collaboration Email Service
2022-12-06 08:58 CEST · 2 hours, 31 minutes

Updates

Resolved

Zugriff wieder uneingeschränkt möglich.

December 6, 2022 · 11:29 CEST
Issue

There is currently a disruption in accessing Exchange mailbox.

We are working hard to find a solution and apologize for the inconvenience.

December 6, 2022 · 08:59 CEST

← Back