Longer processing times for ticket requests

Information Support
2023-12-06 09:12 CEST · 4 months, 2 weeks, 23 hours, 49 minutes

Updates

Resolved

We would like to apologize for the long waiting times when processing tickets. We are aware of the inconvenience and continue to work hard to process requests as quickly as possible.
We thank you for your understanding and patience.

April 19, 2024 · 09:57 CEST
Monitoring

We would like to inform you that there may be delays in processing individual support requests due to the increased volume of tickets in recent weeks.
We apologize for any inconvenience this may cause and thank you for your understanding and cooperation.

December 6, 2023 · 09:12 CEST

← Back