Whiteboard Malfunction

Minor incident Email & Collaboration Whiteboard
2024-02-19 17:44 CEST · 1 week, 1 day, 1 hour, 52 minutes

Updates

Resolved

The problem has been resolved.

February 27, 2024 · 19:36 CEST
Investigating

Disturbances can occurre while using the service. The incident is under investigation.

February 19, 2024 · 17:44 CEST

← Back