MPG-SFX Service is not available

Minor incident General
2025-03-10 22:47 CET · 10 hours, 58 minutes, 1 second

Updates

Resolved

The service is available again without restrictions.

We apologize for any inconvenience caused.

March 11, 2025 · 09:45 CET
Issue

The MPG-SFX Service is temporarily out of order.
We will solve the problem as soon as possible.

March 10, 2025 · 22:47 CET

← Back