Failure of various services

Major incident General
2025-07-03 11:47 CEST · 1 hour, 53 minutes

Updates

Resolved

The fault has been fully rectified.

July 3, 2025 · 12:44 CEST
Update

The cause of the disruption has been rectified. The services are available again, but there may be slight delays in some services until they are fully restored.

July 3, 2025 · 12:04 CEST
Issue

We are currently observing a widespread disruption across various services. The incident is currently being investigated.

July 3, 2025 · 11:47 CEST

← Back