Malfunction Open-Xchange since 28.08.2025 17:00h
Major incident
Email & Collaboration
e-mail
OpenXchange
2025-08-28 17:00 CEST
· 16 hours, 4 minutes
Updates
Resolved
August 29, 2025 · 09:03 CEST
The problem has been resolved and the service is fully available again.
Issue
August 29, 2025 · 07:04 CEST
Ladies and Gentlemen,
unfortunately the Open-Xchange service has been down since yesterday, 28.09.2025 17:00.
At the moment it is not completely clear how quickly the outage can be resolved, but we are of course working at full speed to fix it quickly.
The entire service is affected by the malfunction, including the web interface, sending emails via IMAP/SMTP and receiving emails.
We will inform you as soon as the service is available again and apologize for any inconvenience.
← Back
Status