Client problems after certificate exchange on email.gwdg.de

Major incident Email & Collaboration e-mail Exchange
2025-12-03 09:06 CET · 50 minutes

Updates

Resolved

Access now works again with all e-mail clients.

December 3, 2025 · 09:48 CET
Issue

Some e-mail clients still have access problems after a certificate exchange on email.gwdg.de

We are working on a solution.

December 3, 2025 · 09:06 CET

← Back