Academic Cloud Login/SSO Outage

Major incident General Services Authentication Services Academic Cloud Login
2026-07-16 09:00 CEST · 3 hours

Updates

Resolved

The service is available again without restrictions.

We apologize for any inconvenience caused.

July 16, 2026 · 09:30 CEST
Issue

The SSO login is currently not working. We are aware of the issue and are working hard to find a solution.

July 16, 2026 · 09:05 CEST

← Back