Distribution of the July update for Windows 11 via uni.wsus.gwdg.de has been halted

Information General Services WSUS
2026-07-16 16:09 CEST · 3 days, 18 hours, 47 minutes

Updates

Resolved

The July update for Windows 11 is now available. In the meantime, Microsoft has released an out-of-band update that resolves potential performance issues on Dell computers (see Microsoft).

The out-of-band update cannot be deployed via WSUS, but is available through Windows Update (“Check for updates online”) or the Microsoft Catalog.

July 20, 2026 · 10:14 CEST
Issue

The rollout of the July update for Windows 11 has been temporarily paused due to issues with Dell devices (see Microsoft) has been temporarily paused.

The affected update is KB5101650 for Windows 11 24h2 and 25h2 on uni.wsus.gwdg.de. The update will continue to be distributed via wsus.gwdg.de.

July 16, 2026 · 16:09 CEST

← Back